DIAMS iQは、アプリケーションサーバー、データベースサーバー、ユーザーインターフェイスの3層アーキテクチャにより構成される企業向けソフトウェアソリューションです。Microsoft WebAPI技術によりWindowsサービスとして実装されるDIAMS iQのビジネスロジックを、アプリケーションサーバーがホストします。DIAMS iQのデータは、Microsoft SQL Serverインスタンスによってホストされるデータベースに格納されます。DIAMS iQのユーザーインターフェイスは、Microsoft Smart Client技術で開発されています。DIAMS iQのスマートクライアントは、イントラネットを通して、もしくはHTTPまたはHTTPS/SSLを使用したインターネット接続を介して、アプリケーションサーバーと通信することができます。

スマートクライアントは、マイクロソフトのClickOnceメカニズムを利用して、ワンクリックでインストールできます。ClickOnceアプリケーションのアップデートはユーザーの操作なしで自動的に行われ、他のアプリケーションに影響を与えず、また管理者権限は必要ありません。従来型のMSIパッケージもご要望に応じて提供可能ですが、その場合、ClickOnceのメリット(ワンクリックでのインストール、自動更新、管理者権限不要)はご利用いただけません。クライアントアプリケーションは、信頼できる認証機関(CA)によって発行された証明書を使用して署名されています。

アプリケーションサーバー

  • Windows Server または2012 R2, 2016、 2019
  • Microsoft .NET Framework 4.7
  • Microsoft PowerShell (v4.0以降)
  • Windows Search Service
  • サーバー認証用の証明書
  • DIAMS iQアプリケーションサービスのインストールのため、少なくとも1GBのハードディスク容量
  • 2.5GHz以上のデュアルコアCPU
  • 4GB以上のRAM

データベースサーバー

  • Microsoft SQL Server または 2016 SP2, 2017, 2019(スタンダード・エディション)
  • データベースファイル保存に必要な容量はお客様によって異なります。
  • 2.5GHz以上のデュアルコアCPU
  • 4GB以上のRAM

ユーザーPC

  • Windows 8.1、またはWindows 10
  • Microsoft .NET Framework 4.7
  • Microsoft Office 2010, 2013, 2016, 2019, Microsoft Office 365 (Word、Outlook、およびExcel)
  • Adobe PDF Reader
  • スマートクライアント・アプリケーションのインストールのため、300MBのハードディスク容量
  • 1.5GHz以上のシングルCPUと、少なくとも2GB以上のRAM
  • 1024x768以上の画面解像度
  • ネットワーク帯域幅は、使用量や、ネットワークトラフィックを発生させる他のアプリケーションによって異なりますが、少なくとも500kbit/s以上必要です。

DIAMS Direct

  • Windows Server 2012 R2 またはそれ以降
  • Microsoft SQL Server 2016 SP2 またはそれ以降
  • Internet Information Services 8 以上
  • .NET Framework 4.7
  • SQL Server CLR Types 2014
  • Google Chrome、Firefox、SafariおよびMicrosoft Edgeの最新版を対象に最適化

DIAMS Invent

  • Windows Server 2012 R2 またはそれ以降
  • Microsoft SQL Server 2016 SP2 またはそれ以降
  • Microsoft .Net Framework 4.7
  • SSL Certificate
  • Internet Information Services 8 以上
  • Google Chrome、Firefox、Safari、Microsoft EdgeおよびInternet Explorerの最新版を対象に最適化

DIAMS Collaborate

  • Windows Server 2012 R2またはそれ以降
  • Microsoft SQL Server 2016 SP2またはそれ以降
  • Internet Information Services 8以上
  • SSL Certificate
  • Google Chrome、FirefoxおよびMicrosoft Edgeの最新版を対象に最適化

ダウンロード

システム要件は、印刷可能なPDF形式でダウンロード可能です。

ヘルプデスクへのお問い合わせ

何かご不明な点がございましたら、ヘルプデスクのスタッフまでお尋ねください。