DIAMS iQ is an enterprise software solution with a three-tier architecture comprising application server, database server and user interface. The application server hosts DIAMS iQ's business logic that is implemented as Windows service using Microsoft WebAPI technology. The data of DIAMS iQ is stored in a database hosted by a Microsoft SQL Server instance. The DIAMS iQ user interface is developed in Microsoft Smart Client technology. The DIAMS iQ smart client communicates with the application server via intranet as well as internet connectivity over HTTP or HTTPS/SSL.

The smart client is simply installed by one-click into the user's profile. Updates are automatically downloaded and installed without any user interaction and do not need administrative permissions. Optionally on request we can provide a traditional MSI package to install the DIAMS iQ smart client.

Application Server

  • Windows Server 2012, 2012 R2, 2016 or 2019
  • Microsoft .NET Framework 4.7
  • Microsoft PowerShell (4.0+)
  • SSL Certificate
  • At least 1GB disk space for installing DIAMS iQ application service
  • Dual core CPU running 2.5GHz or higher
  • At least 4GB RAM
  • Adobe® PDF iFilter 64-bit

Database Server

  • Microsoft SQL Server 2012, 2014, 2016, 2017 or 2019 (Standard Edition or higher)
  • Space requirements for storing database files are customer specific.
  • Dual core CPU running 2.5GHz or higher
  • At least 4GB RAM

User PC

  • Windows 8/8.1 or Windows 10
  • Microsoft .NET Framework 4.7
  • Microsoft Office 2010/2013/2016 (Word, Outlook and Excel) and PDF Reader for using Reporting and Mail Merge Features.
  • 100 MB for installing the smart client application
  • Single CPU 1.5 GHz or better and at least 2 GB RAM
  • 1024x768 or higher screen resolution
  • Network bandwidth should be at least 500kbit/s or better depending on usage or other applications creating network traffic.

DIAMS direct

  • Windows Server 2012 or higher
  • Microsoft SQL Server 2012 or higher
  • SSL Certificate
  • Internet Information Services 8 or higher
  • .NET Framework 4.7
  • Optimized for the latest version of Google Chrome, Firefox, Safari and Microsoft Edge

DIAMS invent

  • Windows Server 2012 or higher
  • Microsoft SQL Server 2012 or higher
  • Microsoft .Net Framework 4.7
  • SSL Certificate
  • Internet Information Services 8 or higher
  • Optimized for the latest version of Google Chrome, Firefox, Safari, Microsoft Edge and Internet Explorer

DIAMS collaborate

  • Windows Server 2012 or higher
  • Microsoft SQL Server 2012 or higher
  • Internet Information Services 8 or higher
  • .NET Core 2.0.2
  • SSL Certificate
  • Optimized for the latest version of Google Chrome, Firefox and Microsoft Edge

Download

Get the system requirements as a printable PDF.

Contact Helpdesk

Do you have any questions? Our Helpdesk team is happy to help.